Humaans - Sign in with Google not working for some users – Incident details

Sign in with Google not working for some users

Resolved
Operational
Started 7 months agoLasted 27 minutes

Affected

Platform

Operational from 4:08 PM to 4:35 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently investigating this incident. It looks to be related to a widespread login issue that Google services are experiencing.