Humaans - Major cloud provider outage – Incident details
All systems operational
Major cloud provider outage
Resolved
Operational
Started 17 days agoLasted about 2 hours
Affected
Platform
Operational from 6:36 PM to 8:56 PM
API
Operational from 6:36 PM to 8:56 PM
Updates
Resolved
Resolved
The upstream Google Cloud incident has been resolved. Our platform continues being operational.
Identified
Identified
There is an ongoing major cloud provider outage affecting Google, Amazon, Cloudflare and more affecting multiple internet services. This might lead to interruptions of some services on our platform. We're monitoring the events.