Humaans - Web application unavailable – Incident details

Web application unavailable

Resolved
Partial outage
Started 26 days agoLasted 7 minutes

Affected

Website

Major outage from 2:52 PM to 2:58 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    The web application is currently unavailable to all users - we are investigating the issue.